Are Bareos daemons compatible with Bacula daemons?

The bareos-fd is compatible with all version of the bacula director when you enable the compatible mode in the config of the file daemon. Currently the compatible option is on by default but that may change in the future. To be sure this is enabled you can explicitly set the compatible option by putting the following in the bareos-fd.conf:

compatible=true

A Bareos Director and a Bareos Storage Daemon should always run at the same version. This is because the protocol between Director and Storage Daemon itself is not versioned (also true for Bacula). If you want to be able to switch back to using bacula after using a bareos director and storage daemon you have to enable the compatible mode in the storage daemon (which is currently the default) to have it write the data in the same format as the bacula storage daemon. As bareos director can only talk to file daemons of version 2.0 or higher (as 2.0 is almost 6 years old that shouldn't be a problem however some distributions still deliver a 1.38 version which is known not to work with the bareos director as we don't support the old runscript protocol (if you don't use runscripts this should not be a problem and the director will most likely work with older file daemons too. We would only advise to upgrade the filed as its getting to old.)

 

Other combinations like Bacula director (dir) with Bareos storage daemon (sd) will not work. However this wasn't even possible with different versions of bacula-dir and bacula-sd.

Last update on 2013-07-19 by Marco van Wieringen.

Go back